WordPress and PHP8

PHP programming forum. Ask questions or help people concerning PHP code. Don't understand a function? Need help implementing a class? Don't understand a class? Here is where to ask. Remember to do your homework!

Moderator: General Moderators

Post Reply
User avatar
Vegan
Forum Regular
Posts: 565
Joined: Fri Sep 05, 2008 3:34 pm
Location: Victoria, BC

WordPress and PHP8

Post by Vegan »

It seems that WordPress 5.7.1 works way better with PHP8, it seems many functions to not like PHP 7.4 go figure. I also am using MySQL 8. Manuals are widely available for everything.

Code: Select all

sudo add-apt-repository ppa:ondrej/php
sudo apt install  ca-certificates apt-transport-https software-properties-common
sudo apt install php8.0 libapache2-mod-php8.0
sudo apt install php8.0-fpm libapache2-mod-fcgid
sudo a2enmod proxy_fcgi setenvif
sudo a2enconf php8.0-fpm
sudo apt instal php-curl
sudo apt install php8.0-xml
sudo apt install php-mbstring
sudo apt install php-imagick
sudo apt install php-zip
sudo systemctl restart apache2
sudo apt remove php7.4
sudo apt autoremove
sudo apt update
sudo apt upgrade
Hardcore Games™ Legendary is the Only Way to Play™
Post Reply