PHP Developers Network

A community of PHP developers offering assistance, advice, discussion, and friendship.
 
Loading
It is currently Sun Nov 23, 2014 9:38 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sat Jun 06, 2009 4:03 pm 
Offline
DevNet Evangelist

Joined: Tue Dec 21, 2004 6:00 pm
Posts: 6259
Location: Winnipeg
I have tried googling and several different things and get the same result everytime:

Syntax: [ Download ] [ Hide ]
spectra-server:/usr/lib# pear install phpunit/PHPUnit
Did not download optional dependencies: pear/Image_GraphViz, pear/Log, use --alldeps to download automatically
phpunit/PHPUnit requires PEAR Installer (version >= 1.8.1), installed version is 1.4.11
phpunit/PHPUnit can optionally use package "pear/Image_GraphViz" (version >= 1.2.1)
phpunit/PHPUnit can optionally use package "pear/Log"
phpunit/PHPUnit can optionally use PHP extension "pdo_sqlite"
phpunit/PHPUnit can optionally use PHP extension "xdebug" (version >= 2.0.0)
No valid packages found
install failed


I have tried

Syntax: [ Download ] [ Hide ]
apt-get upgrade
apt-get update


And I even tried

Syntax: [ Download ] [ Hide ]
apt-get dist-upgrade


Then re-ran the first command at top and still...same warning. I fear I may have to installéupgrade PEAR to 1.8.1 manually but I have done this only a few times from sources and don`t really feel in the mood for tinkering with Linux right now.

Any ideas...


Top
 Profile  
 
PostPosted: Sat Jun 06, 2009 4:12 pm 
Offline
Moderator
User avatar

Joined: Mon Nov 03, 2003 7:13 pm
Posts: 5920
Location: Odessa, Ukraine
I guess it should be something like this:
Syntax: [ Download ] [ Hide ]
 
sudo pear upgrade PEAR
 


Top
 Profile  
 
PostPosted: Sat Jun 06, 2009 6:49 pm 
Offline
DevNet Evangelist

Joined: Tue Dec 21, 2004 6:00 pm
Posts: 6259
Location: Winnipeg
I tried that but still version errors:

Syntax: [ Download ] [ Hide ]
 
spectra-server:~# pear upgrade PEAR
pear/Archive_Tar requires PEAR Installer (version >= 1.5.4), installed version is 1.4.11
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.3.1 is not the recommended version 1.3.3, but may be compatible, use --force to install
downloading Console_Getopt-1.2.3.tgz ...
Starting to download Console_Getopt-1.2.3.tgz (4,011 bytes)
....done: 4,011 bytes
upgrade ok: channel://pear.php.net/Console_Getopt-1.2.3
spectra-server:~#


Am I running a really old version of Debian or something? I could swear I downloaded the latest version 5.0 -- but it's possible I installed an older copy.

Wouldn't apt-get upgrade or update bring my whole system to the latest version?


Top
 Profile  
 
PostPosted: Sat Jun 06, 2009 7:05 pm 
Offline
Moderator
User avatar

Joined: Mon Nov 03, 2003 7:13 pm
Posts: 5920
Location: Odessa, Ukraine
PCSpectra wrote:
I tried that but still version errors:

Syntax: [ Download ] [ Hide ]
 
spectra-server:~# pear upgrade PEAR
[...]
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.3.1 is not the recommended version 1.3.3, but may be compatible, <span style="font-weight: bold"><span style="font-size: 150%; line-height: normal">use --force to install</span></span>
[...]
 



PCSpectra wrote:
Wouldn't apt-get upgrade or update bring my whole system to the latest version?

dist-upgrade should update your system to the latest (stable?) Debian, sure. But it doesn't mean you would get latest versions of all software included in debian - only latest debian versions. And if you are running debian stable (and I guess you do, based on our previous conversations) these would be quite outdated versions.


Top
 Profile  
 
PostPosted: Mon Jun 08, 2009 5:19 pm 
Offline
DevNet Evangelist

Joined: Tue Dec 21, 2004 6:00 pm
Posts: 6259
Location: Winnipeg
OK I have no idea what I'm doing wrong but still I'm getting errors:

Syntax: [ Download ] [ Hide ]
 
<span style="font-weight: bold">attempt one:</span>
 
spectra-server:~# pear upgrade PEAR --force
parsePackageName(): invalid package name "--force" in "--force"
invalid package name/package file "--force"
Cannot initialize '--force', invalid or missing package file
pear/Archive_Tar requires PEAR Installer (version >= 1.5.4), installed version is 1.4.11
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.3.1 is not the recommended version 1.3.3, but may be compatible, use --force to install
Package "--force" is not valid
No valid packages found
upgrade failed
 
<span style="font-weight: bold">attempt two:</span>
 
spectra-server:~# pear upgrade PEAR use --force
No releases available for package "pear.php.net/use"
Cannot initialize 'use', invalid or missing package file
parsePackageName(): invalid package name "--force" in "--force"
invalid package name/package file "--force"
Cannot initialize '--force', invalid or missing package file
pear/Archive_Tar requires PEAR Installer (version >= 1.5.4), installed version is 1.4.11
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.3.1 is not the recommended version 1.3.3, but may be compatible, use --force to install
Package "use" is not valid
Package "--force" is not valid
No valid packages found
upgrade failed


Top
 Profile  
 
PostPosted: Mon Jun 08, 2009 5:25 pm 
Offline
Moderator
User avatar

Joined: Mon Nov 03, 2003 7:13 pm
Posts: 5920
Location: Odessa, Ukraine
order of arguments matters:
Syntax: [ Download ] [ Hide ]
 
pear upgrade --force PEAR
 


Top
 Profile  
 
PostPosted: Mon Jun 08, 2009 5:41 pm 
Offline
DevNet Evangelist

Joined: Tue Dec 21, 2004 6:00 pm
Posts: 6259
Location: Winnipeg
Excellent thank you :)


Top
 Profile  
 
PostPosted: Tue Mar 02, 2010 3:56 pm 
Offline
Forum Newbie

Joined: Tue Mar 02, 2010 3:52 pm
Posts: 1
I tried the --force option, looked like everything went ok, but not version does not change, and trying to install phing will fail requiring > v1.8 ...

--
D:\xampp\php>pear upgrade --force PEAR

downloading PEAR-1.9.0.tgz ...
Starting to download PEAR-1.9.0.tgz (291,634 bytes)
.............................................................done: 291,634 bytes

upgrade ok: channel://pear.php.net/PEAR-1.9.0

PEAR: Optional feature webinstaller available (PEAR's web-based installer)
PEAR: Optional feature gtkinstaller available (PEAR's PHP-GTK-based installer)
PEAR: Optional feature gtk2installer available (PEAR's PHP-GTK2-based installer)
PEAR: To install optional features use "pear install pear/PEAR#featurename"

D:\xampp\php>pear channel-discover pear.phing.info
Channel "pear.phing.info" is already initialized

D:\xampp\php>pear install phing/phing
Did not download optional dependencies: phing/phingdocs, pear/VersionControl_SVN, channel://pear.phpunit.de/PHPUnit, pecl/
Xdebug, pear/PEAR_PackageFileManager, use --alldeps to download automatically

phing/phing requires PEAR Installer (version >= 1.8.0), installed version is 1.7.2

phing/phing can optionally use package "phing/phingdocs" (version >= 2.4.0)
phing/phing can optionally use package "pear/VersionControl_SVN" (version >= 0.3.2)
phing/phing can optionally use package "channel://pear.phpunit.de/PHPUnit" (version >= 3.4.0)
phing/phing can optionally use package "pecl/Xdebug" (version >= 2.0.5)
phing/phing can optionally use package "pear/PEAR_PackageFileManager" (version >= 1.5.2)

No valid packages found
install failed

D:\xampp\php>pear version

PEAR Version: 1.7.2
PHP Version: 5.2.9
Zend Engine Version: 2.2.0
Running on: Windows NT LAPTOP 6.0 build 6002


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group